Infogreffe
39043 updates completed on 22/05/2019
COMPATIBLE BROWSERS

Your browser is not compatible with the Infogreffe website. Some parts of the site may not function properly. We strongly recommend that you update your browser. To assist you, below is a list of browsers that are compatible with the Infogreffe website categorized by operating system.

Windows

  • Internet Explorer 7 or higher
  • Firefox 1.0 or higher

Linux

  • Firefox 1.0 or higher

Mac OS X

  • Safari 2.0 or higher
  • Firefox 1.0 or higher